Choose style:

Author Topic: Installed sound card choice (SOLVED)  (Read 2490 times)

0 Members and 1 Guest are viewing this topic.

Offline rwbroers

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
Installed sound card choice (SOLVED)
« on: April 02, 2014, 06:23:59 am »
I have two sound cards in my pc.  One is on the motherboard and the other is a Sound Blaster.  The onboard is listed as CM6501, the soundblaster is listed as SB Live! EMU10k1.  The system default is currently the onboard CM6501.  I want the default set to the SB Live! EMU10k1.  How can I change this in my Peppermint 4/32 bit installation? 

And are we going to have to do this captcha stuff all the time, as the pics are blury and it takes quite a long time to do and is often incorrect for me.
« Last Edit: April 03, 2014, 08:08:29 pm by rwbroers »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25083
  • Karma: 2777
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed sound card choice
« Reply #1 on: April 02, 2014, 06:39:17 am »
Try this .. Open a terminal and run:

Code: [Select]
gedit ~/.asoundrc
When gedit opens a BLANK file (if it's not blank, STOP NOW and post its contents) .. make it read:-

Code: [Select]
pcm.!default {
type hw
card 1
}

ctl.!default {
type hw
card 1
}
SAVE the file and reboot to test sound.



You can always undo the changes by deleting the ~/.asoundrc file:

Code: [Select]
rm ~/.asoundrc
and rebooting
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rwbroers

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
Re: Installed sound card choice
« Reply #2 on: April 02, 2014, 06:51:59 pm »
@PCNetSpec

Tried suggested, no luck.  Even tried changing the number from 1 to 2 and 0, still no luck.  Any other suggestions?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25083
  • Karma: 2777
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed sound card choice
« Reply #3 on: April 03, 2014, 06:01:17 am »
OK, can we first check if this soundblaster even works with Linux.

First go into your BIOS and disable the onboard sound card .. then boot .. does sound work now (from the soundblaster) ?



If not...

Open a terminal and run:
Code: [Select]
alsamixer
Then hit the F6 key and make sure the soundblaster is selected .. does sound work now ?



If not, hit the Esc key to exit alsamixer and run::
Code: [Select]
sudo apt-get install pulseaudio pulseaudio-utils pavucontrol
you'll then find a new menu item
menu > Sound & Video > PulseAudio Volume Control

open that, and have a look to see if the soundblaster is an option from any of the tabs.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rwbroers

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
Re: Installed sound card choice
« Reply #4 on: April 03, 2014, 08:06:48 pm »
Disabled the mb sound device in bios, that did the trick.  SB working fine now.

It always played sound, just was totally distorted and was a major pain when using voip software.

Tried running the "open terminal, run alsamixer".  Here is what it returned.

ron@ron-System-Product-Name ~ $ alsamixer
cannot open mixer: No such file or directory

Kinda mute, but thought I would include it, to let you know that the alsamixer wasn't installed

Thanks.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25083
  • Karma: 2777
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed sound card choice (SOLVED)
« Reply #5 on: April 03, 2014, 08:39:11 pm »
Glad to hear it's now working.

Did you ever delete the .asoundrc file we created earlier ?

if not, run:
Code: [Select]
rm -v ~/.asoundrc
then REBOOT

Now see if:
Code: [Select]
alsamixer
works ?
(if it does, don't change anything .. I'm just trying to see if that's fixed it)
« Last Edit: April 03, 2014, 08:43:47 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rwbroers

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
Re: Installed sound card choice (SOLVED)
« Reply #6 on: April 06, 2014, 11:12:13 pm »
Removed the file we created, rebooted and the mixer was there now.  All seems well.  Thanks again.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25083
  • Karma: 2777
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Installed sound card choice (SOLVED)
« Reply #7 on: April 07, 2014, 03:48:43 am »
No problem .. thanks for marking the topic solved :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec