Choose style:

Author Topic: LED indicators  (Read 2662 times)

0 Members and 1 Guest are viewing this topic.

Offline hofy

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 6
    • View Profile
  • Peppermint version(s): 6, 8
LED indicators
« on: October 13, 2014, 02:35:23 pm »
Hi,

I have peppermint 5 on an ancient asus w5a laptop and I wonder if there is any way I can turn off the bluetooth LED indicator? I can't find any keyboard shortcut that would service the indicator. Wifi indicator sort of shuts down after rfkill, but on bluetooth this has absolutely no effect. the wireless mouse continues to work (shipped with laptop) no matter what.
is there a command that would turn off all LEDs? I tried xset led from 1 to 10, nothing.

it's not a big deal, but if there's a trick, I want to know :)
thank you

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: LED indicators
« Reply #1 on: October 13, 2014, 05:02:37 pm »
I take it you want to disable bluetooth all together ?

What happens if you run:
Code: [Select]
sudo echo "0"  > /proc/acpi/asus/bluetooth

and what's the output from:
Code: [Select]
lsmod | grep asus
and
Code: [Select]
rfkill list



For my reference:
https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/25610
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 6
    • View Profile
  • Peppermint version(s): 6, 8
Re: LED indicators
« Reply #2 on: October 14, 2014, 04:40:37 am »
Bluetooth I have disabled via the manager. I am not aware of a hardware switch. in WinXP the indicator is off.

output :
hofy@hofy-W5A ~ $ sudo echo "0"  > /proc/acpi/asus/bluetooth
bash: /proc/acpi/asus/bluetooth: No such file or directory
hofy@hofy-W5A ~ $ lsmod | grep asus
asus_laptop            23897  0
sparse_keymap          13708  1 asus_laptop
input_polldev          13648  1 asus_laptop
hofy@hofy-W5A ~ $ rfkill list
0: hci0: Bluetooth
   Soft blocked: yes
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: LED indicators
« Reply #3 on: October 14, 2014, 11:21:01 am »
What's the output from:
Code: [Select]
lsmod
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 6
    • View Profile
  • Peppermint version(s): 6, 8
Re: LED indicators
« Reply #4 on: October 16, 2014, 07:59:04 am »
lsmod output:
Spoiler (click here to view / hide)
hofy@hofy-W5A ~ $ lsmod
Module                  Size  Used by
michael_mic            12540  8
arc4                   12536  4
lib80211_crypt_tkip    17456  2
bnep                   18895  2
rfcomm                 53664  8

dm_crypt               22589  0
snd_hda_codec_realtek    55163  1
btusb                  27580  0
bluetooth             342208  22 bnep,btusb,rfcomm
snd_hda_intel          42730  3
snd_hda_codec         164067  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13272  1 snd_hda_codec
snd_pcm                85501  2 snd_hda_codec,snd_hda_intel
snd_page_alloc         14230  2 snd_pcm,snd_hda_intel
snd_seq_midi           13132  0
snd_seq_midi_event     14475  1 snd_seq_midi
snd_rawmidi            25135  1 snd_seq_midi
r852                   17722  0
sm_common              16772  1 r852
joydev                 17101  0
pcmcia                 51828  0
nand                   58760  2 r852,sm_common
ipw2200               136401  0
snd_seq                55383  2 snd_seq_midi_event,snd_seq_midi
nand_ecc               13136  1 nand
nand_bch               13067  1 nand
serio_raw              13230  0
bch                    17197  1 nand_bch
nand_ids                8547  1 nand
libipw                 33144  1 ipw2200
mtd                    52813  2 nand,sm_common
lib80211               14040  3 lib80211_crypt_tkip,libipw,ipw2200
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
r592                   17711  0
snd_timer              28584  2 snd_pcm,snd_seq
yenta_socket           40201  0
lpc_ich                16864  0
cfg80211              409394  2 libipw,ipw2200
memstick               16174  1 r592
pcmcia_rsrc            18319  1 yenta_socket
asus_laptop            23897  0
pcmcia_core            22328  3 pcmcia,pcmcia_rsrc,yenta_socket
snd                    60939  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
mac_hid                13037  0
sparse_keymap          13708  1 asus_laptop
soundcore              12600  1 snd
input_polldev          13648  1 asus_laptop
parport_pc             31981  0
ppdev                  17391  0
lp                     13299  0
parport                40836  3 lp,ppdev,parport_pc
hid_generic            12492  0
usbhid                 47070  0
hid                    87604  2 hid_generic,usbhid
i915                  709755  3
i2c_algo_bit           13197  1 i915
sdhci_pci              18535  0
firewire_ohci          35529  0
drm_kms_helper         48868  1 i915
8139too                32571  0
8139cp                 27171  0
psmouse                91329  0
sdhci                  37779  1 sdhci_pci
firewire_core          61867  1 firewire_ohci
drm                   244037  4 i915,drm_kms_helper
mii                    13654  2 8139cp,8139too
crc_itu_t              12627  1 firewire_core
video                  18903  1 i915
[close]
apparently bluetooth module gets loaded even tho I disabled it in bluetooth manager.
i tried to modprobe -r bluetooth and dependencies bnep, rfcomm, btusb. only btusb didn't give errors:

hofy@hofy-W5A ~ $ sudo modprobe -rf btusb
hofy@hofy-W5A ~ $ sudo modprobe -rf rfcomm
modprobe: FATAL: Module rfcomm is in use.
hofy@hofy-W5A ~ $ sudo modprobe -rf bnep
modprobe: FATAL: Module bnep is in use.
hofy@hofy-W5A ~ $ sudo modprobe -rf bluetooth
modprobe: FATAL: Module bluetooth is in use.

how to stop and remove these?
thanks
« Last Edit: October 16, 2014, 08:13:51 am by AndyInMokum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: LED indicators
« Reply #5 on: October 16, 2014, 08:03:28 am »
What's the output from:
Code: [Select]
dpkg -l | grep blue
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: LED indicators
« Reply #6 on: October 16, 2014, 08:12:58 am »
Hi hofy.  I see that the output you returned is very long.  In future, could you please encapsulate long outputs with the SpSpoiler function.  This is located just above the crying  :'( emoticon.  It makes it much easier for people to read and keeps things neat and tidy.  This time Iíve done this for you.  Thanks in advance ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline hofy

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 6
    • View Profile
  • Peppermint version(s): 6, 8
Re: LED indicators
« Reply #7 on: October 16, 2014, 08:19:12 am »
hofy@hofy-W5A ~ $ dpkg -l | grep blue
ii  blueman                                    1.23-git201403102151-1ubuntu1          i386         Graphical bluetooth manager
ii  bluez                                      4.101-0ubuntu13                        i386         Bluetooth tools and daemons
ii  libbluetooth3:i386                         4.101-0ubuntu13                        i386         Library to use the BlueZ Linux Bluetooth stack
ii  libgnome-bluetooth11                       3.8.2.1-0ubuntu4.1                     i386         GNOME Bluetooth tools - support library


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: LED indicators
« Reply #8 on: October 16, 2014, 09:19:08 am »
OK, if you don't want bluetooth at all, run:
Code: [Select]
sudo apt-get remove --purge blueman bluez
then
Code: [Select]
sudo gedit /etc/modprobe.d/blacklist.conf
when a file opens that already has some stuff in it, addd a single NEW line at the bottom that reads:-

blacklist bluetooth

SAVE the file and exit gedit.

REBOOT.

Now post the output from:
Code: [Select]
lsmod | grep bluetooth
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 6
    • View Profile
  • Peppermint version(s): 6, 8
Re: LED indicators
« Reply #9 on: October 17, 2014, 06:54:41 am »
I did as suggested, after reboot I modprobed btusb and bluetooth, blacklisted btusb as well and it no longer shows in lsmod or rfkill:

hofy@hofy-W5A ~ $ lsmod | grep bluetooth
hofy@hofy-W5A ~ $ rfkill list
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
hofy@hofy-W5A ~ $

strangely enough, the LED is still ON! and the mouse works as well. at startup, I can read in the boot messages:
stopping bluetooth daemon [fail]


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: LED indicators
« Reply #10 on: October 17, 2014, 12:42:58 pm »
OK it must be part of the kernel then

As long as blacklist.conf still contains the "blacklist bluetooth" line, run:
Code: [Select]
sudo update-initramfs -u
Now try rebooting
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 6
    • View Profile
  • Peppermint version(s): 6, 8
Re: LED indicators
« Reply #11 on: October 17, 2014, 01:47:19 pm »
same as my previous post, no change.

Offline hofy

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 6
    • View Profile
  • Peppermint version(s): 6, 8
Re: LED indicators
« Reply #12 on: October 25, 2014, 06:51:10 pm »
I paid close attention as to when exactly the indicator turns on, and it seems to be the line

starting modules from /etc/modules. strangely enough, the file is basically empty (all commented out).

these lines flash by as the indicator turns on:
 * Starting device node and kernel event manager[ OK ]
 * Starting load modules from /etc/modules[ OK ]
 * Starting cold plug devices[ OK ]
 * Starting log initial device creation[ OK ]
 * Stopping load modules from /etc/modules[ OK ]
 * Starting configure network device security[ OK ]
 * Starting configure network device[ OK ]
 * Starting configure network device security[ OK ]
 * Starting Mount network filesystems[ OK ]
 * Stopping Mount network filesystems[ OK ]
 * Starting configure network device[ OK ]
 * Starting Bridge socket events into upstart[ OK ]
 * Starting configure network device security[ OK ]
 * Starting configure network device[ OK ]