Choose style:

Author Topic: scroll one line in firefox?  (Read 1320 times)

0 Members and 1 Guest are viewing this topic.

Offline kevinbanjo

  • Jr. Member
  • **
  • Posts: 62
  • Karma: 0
  • New Forum User
    • View Profile
scroll one line in firefox?
« on: October 31, 2014, 07:47:32 pm »
When using firefox (and probably other apps) peppermint is the only place where I have not seen the little arrows at the top and bottom of the scroll bar where you can scroll the buffer one line and its really annoying because my notebook is really slow and its very difficult to use the touch pad to position the buffer where you want.  Anyone know of a way to turn them on system wide?   How about just for firefox?

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: scroll one line in firefox?
« Reply #1 on: October 31, 2014, 07:51:35 pm »
what gtk theme are you using? im currently using a theme polar night and it has a very very thin scroll bar th at appears only when you hover it.
i actually noticed firefox is the only brower that actually uses the gtk themes scroll bars. chrome and chromium  for some reason do not so i actually
used an add on to hide them all togther.
http://iamesper.bandcamp.com
boring drone music from NJ

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26277
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: scroll one line in firefox?
« Reply #2 on: October 31, 2014, 09:01:49 pm »
If you're using the default Peppermint 5 gtk-2.0 theme (Peppermint-Light), open a terminal and run:
Code: [Select]
sudo gedit /usr/share/themes/Peppermint-Light/gtk-2.0/gtkrc
find the lines:-
Code: [Select]
	GtkScrollbar::has-backward-stepper = 0
GtkScrollbar::has-forward-stepper = 0
and change the two instances of "0" to "1" .. so those 2 lines now read:-
Code: [Select]
	GtkScrollbar::has-backward-stepper = 1
GtkScrollbar::has-forward-stepper = 1
SAVE the file.

Close ALL running instances of Firefox .. and restart Firefox.

You may need to log off/on again for the changes to also be applied to the file manager.



You should also be able to change the same 2 lines in the gtk-2.0 > gtkrc file for any other theme you happen to be using.

To find which gtk-2.0 theme you're using, go to
menu > Preferences > Customise Look and Feel > Widget (tab)
whatever is highlighted on the left is the gtk-2.0 theme you're using.
« Last Edit: October 31, 2014, 09:15:27 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec