Choose style:

Author Topic: Hotkeys volume up volume down and mute not working  (Read 5263 times)

0 Members and 1 Guest are viewing this topic.

Offline freckles80

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
Hotkeys volume up volume down and mute not working
« on: September 26, 2014, 04:58:29 pm »
Hi all
Today I was watching a youtube video and realized about this problem.
These multimedia keys don't work. (brightness up-down didn't either but I managed to fix that)

Using xev in terminal I get this when I press on them:
Code: [Select]
FocusOut event, serial 37, synthetic NO, window 0x3400001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 37, synthetic NO, window 0x3400001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

I am using a lenovo laptop (G510)
I have been trying some of the suggestions I have read about, but no luck.
I would appreciate your help.
Thanks

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Hotkeys volume up volume down and mute not working
« Reply #1 on: September 26, 2014, 06:27:51 pm »
Do you mean the F1 - F12 keys are acting ONLY as F1 - F12 keys .. and not as Multimedia keys ?
ie. you've toggled the Hotkey Switch to Legacy Mode in the BIOS .. as shown here:
https://forums.lenovo.com/t5/Lenovo-3000-and-Essential/G510-Fn-key-and-display-card-problems/td-p/1266803

If so, are you holding the Fn key whilst hitting the volume up/down keys ?
as described here:
https://superuser.com/questions/688343/enable-f1-f12-keys-without-fn-on-lenovo-ideapad-s400u
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline freckles80

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5 x64
Re: Hotkeys volume up volume down and mute not working
« Reply #2 on: September 27, 2014, 02:57:36 pm »
Thanks for the reply!

I changed what you suggested in BIOS, changed it from "enabled" to "disabled"
Now when I press on those keys, xev running in terminal I get:
Code: [Select]
KeyPress event, serial 37, synthetic NO, window 0x2600001,
    root 0x9c, subw 0x0, time 199877, (-55,-91), root:(536,578),
    state 0x0, keycode 67 (keysym 0xffbe, F1), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x2600001,
    root 0x9c, subw 0x0, time 200032, (-55,-91), root:(536,578),
    state 0x0, keycode 67 (keysym 0xffbe, F1), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x2600001,
    root 0x9c, subw 0x0, time 201658, (-55,-91), root:(536,578),
    state 0x0, keycode 68 (keysym 0xffbf, F2), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x2600001,
    root 0x9c, subw 0x0, time 201792, (-55,-91), root:(536,578),
    state 0x0, keycode 68 (keysym 0xffbf, F2), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x2600001,
    root 0x9c, subw 0x0, time 205915, (-55,-91), root:(536,578),
    state 0x0, keycode 69 (keysym 0xffc0, F3), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x2600001,
    root 0x9c, subw 0x0, time 206044, (-55,-91), root:(536,578),
    state 0x0, keycode 69 (keysym 0xffc0, F3), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

Mute key, Volume -, Volume + (F1, F2, F3)

Now for the rest of the multimedia keys to work I have to press Fn too.
But volume keys are still not working (pressing on Fn at the same time or not, they don't work)
« Last Edit: September 27, 2014, 03:03:28 pm by freckles80 »

Offline jsb

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 5
Re: Hotkeys volume up volume down and mute not working
« Reply #3 on: November 22, 2014, 08:25:04 am »
I have this issue too. Also had this problem with P4, never did get it to work.

I was going to try changing the keyboard shortcut settings, using instructions that were provided here:
http://peppermintos.net/viewtopic.php?f=8&t=6128&hilit=volume&start=0

but the interface has changed and there is no "get key" button.

Here's the keyboard shortcut settings screen:




FWIW, the volume shortcut keys did work in Mint 17 XFCE, I'd been using that since tha LTS version came out. (Slow web page loading in mint is what has me coming back to peppermint on this machine.)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Hotkeys volume up volume down and mute not working
« Reply #4 on: November 22, 2014, 08:31:27 pm »
Which key combos worked in Mint for both volume-up and volume-down ?

If we can work out the key combos/commands used by Mint, we should be able to manually edit the keyboard shortcuts.

Have you still got Mint (even on a LiveUSB/CD) ?
« Last Edit: November 22, 2014, 08:45:05 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jsb

  • Jr. Member
  • **
  • Posts: 27
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): peppermint 5
Re: Hotkeys volume up volume down and mute not working
« Reply #5 on: November 22, 2014, 09:57:35 pm »
Fn+F1 was volume down, Fn+F2 was volume up and Fn+Esc was mute, this matches the way the keyboard is labeled. I do have the live DVD with Mint.