Choose style:

Author Topic: Problems getting Skype to autostart. [SOLVED]  (Read 5168 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Problems getting Skype to autostart. [SOLVED]
« on: March 30, 2014, 06:01:12 am »
Sunday greetings from a very sunny morning in Amsterdam.  I'm trying to get Skype to autostart after a 15sec delay.  I've created a little sleep script that's been tested and it works.
Code: [Select]
#!/bin/bash
sleep 15
display=:0.0 skype -c /usr/share/applications/Skype
This is where I'm stuck.  This is what I have in my Autostart for Skype:
Code: [Select]
[Desktop Entry]
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false

When I log in or, boot, autostart doesn't find skype-15sec-delay.sh.  I have to be doing something really stupid and I can't see it.  Any suggestions?  :)

Just to add: I have other items in Autostart and when I open them I see that files such as my Conky Autostart have colours in the text after it is saved.  The file I created for Skype remains in monochrome after it is has been saved.  I don't know if this indicates something or not. 
« Last Edit: March 31, 2014, 09:34:12 am by PCNetSpec, Reason: Marked as [SOLVED] »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems getting Skype to autostart.
« Reply #1 on: March 30, 2014, 07:54:14 am »
Try adding a "Type=Application" line to your .desktop file

Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false

if that still doesn't work, post the output from:
Code: [Select]
ls -a ~/.config/autostart
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Problems getting Skype to autostart.
« Reply #2 on: March 30, 2014, 08:26:34 am »
Thanks for that.  I tried inserting that line, saved and did a restart.  It still didn't work.  Here is the requested output from
Code: [Select]
ls -a ~/.config/autostart
:
Spoiler (click here to view / hide)
andy@andy-AMILO-Li3710 ~ $ ls -a ~/.config/autostart
.                               skype-15sec-delay.sh
..                              spideroak-custom-autostart.desktop
conky-autostart-5sec-delay.sh~  spideroak-custom-autostart.desktop~
conky-autostart-6sec-delay.sh   terminator-autostart-25sec-delay.sh
conky-autostart.desktop         terminator-autostart.desktop
conky-autostart.desktop~        touchpad-pause.desktop
docky.desktop                   Unstarted
dropbox.desktop                 xfce4-power-manager.desktop
gnome-keyring-gpg.desktop       xfce4-power-manager.desktop~
shutter.desktop
andy@andy-AMILO-Li3710 ~ $
[close]
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems getting Skype to autostart.
« Reply #3 on: March 30, 2014, 11:46:55 am »
So where is the file that reads:
Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false
and what is it called ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Problems getting Skype to autostart.
« Reply #4 on: March 30, 2014, 01:14:58 pm »
So where is the file that reads:
Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false
and what is it called ?

Sorry, I'm not sure if I'm understanding the question correctly.  I have the Skype delayed start script located at:
Code: [Select]
/home/andy/.config/autostart
The name of the file is:
Code: [Select]
skype-15sec-delay.sh
I hope that is what you are looking for.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems getting Skype to autostart.
« Reply #5 on: March 30, 2014, 01:51:34 pm »
In your original post you said...

This is what I have in my Autostart for Skype:
Code: [Select]
[Desktop Entry]
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false

You then went on to say

Quote
The file I created for Skype remains in monochrome after it is has been saved.

Where is this file, and what is it called ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Problems getting Skype to autostart.
« Reply #6 on: March 30, 2014, 02:20:05 pm »
In your original post you said...

This is what I have in my Autostart for Skype:
Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false

You then went on to say

Quote
The file I created for Skype remains in monochrome after it is has been saved.

Where is this file, and what is it called ?

Sorry, I had to think for a moment.  I think we've got our wires crossed.
Quote
The file I created for Skype remains in monochrome after it is has been saved.
This should have read:
Quote
This  file I just created for the Skype autostart remains in monochrome after it is has been saved.
  It is this file I'm speaking of:
Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Type=Application
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false
After this is saved, the labels: Name, Comment, Exec and Terminal remain in regular mono chrome.  Other autostart items that I have created, the labels change colour on save.  I hope that's ironed out the confusion.  Sorry about that  :-[!
« Last Edit: March 30, 2014, 02:34:00 pm by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Problems getting Skype to autostart.
« Reply #7 on: March 30, 2014, 04:07:14 pm »
In your original post you said...

This is what I have in my Autostart for Skype:
Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false

You then went on to say

Quote
The file I created for Skype remains in monochrome after it is has been saved.

Where is this file, and what is it called ?

Sorry, I had to think for a moment.  I think we've got our wires crossed.
Quote
The file I created for Skype remains in monochrome after it is has been saved.
This should have read:
Quote
This  file I just created for the Skype autostart remains in monochrome after it is has been saved.
  It is this file I'm speaking of:
Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Type=Application
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false
After this is saved, the labels: Name, Comment, Exec and Terminal remain in regular mono chrome.  Other autostart items that I have created, the labels change colour on save.  I hope that's ironed out the confusion.  Sorry about that  :-[!

It is as if the .desktop file I created is not being recognized.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems getting Skype to autostart.
« Reply #8 on: March 30, 2014, 06:41:08 pm »
I repeat .. where is the .desktop file ?

and what is it called ?

Gimme the full path to the .desktop file.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Problems getting Skype to autostart.
« Reply #9 on: March 30, 2014, 07:09:34 pm »
Hi and thanks for the help.  Sorry for being thick but I am not too sure what the .desktop file is. I'm hoping that this is it. 
Code: [Select]
/home/andy/config/autostart/SkypeAutostart

I was having trouble yesterday with my screen blanking out ever 10 min.  Mac suggested I enter
Code: [Select]
xset s 0 0
to disable the blanking for the session.  To make it more permanent, the Lubuntu forum suggests editing .profile by adding
Code: [Select]
xset s 0 0
to the start of the file so it looks like this:
Spoiler (click here to view / hide)
xset s 0 0
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.
# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022
# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
   . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi
[close]
Could this be causing the problem?  I hope not because it appears to be working.  I hope this helps and more importantly, I hope I've given you the right info.  Many thanks
« Last Edit: March 31, 2014, 02:22:53 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems getting Skype to autostart.
« Reply #10 on: March 30, 2014, 07:57:43 pm »
No ..

What's causing the problem is the file that is in monochrome .. it needs fixing

But here's MY problem .. you keep saying yoou've changed it's contents, but I have NO IDEA where this file is on your system or what it's called.

You SAY it's at
/home/andy/config/autostart/SkypeAutostart
(is that a typo btw "config" instead of ",config" ?)

but your earlier listing of that directory doesn't show it
Code: [Select]
andy@andy-AMILO-Li3710 ~ $ ls -a ~/.config/autostart
.                               skype-15sec-delay.sh
..                              spideroak-custom-autostart.desktop
conky-autostart-5sec-delay.sh~  spideroak-custom-autostart.desktop~
conky-autostart-6sec-delay.sh   terminator-autostart-25sec-delay.sh
conky-autostart.desktop         terminator-autostart.desktop
conky-autostart.desktop~        touchpad-pause.desktop
docky.desktop                   Unstarted
dropbox.desktop                 xfce4-power-manager.desktop
gnome-keyring-gpg.desktop       xfce4-power-manager.desktop~
shutter.desktop
andy@andy-AMILO-Li3710 ~ $
I could easily tell you how to add a .desktop file that would autostart your script .. but you may end up with 2 .. so It would be nice to track down the file and either delete it, or fix it.

What's the output from:
Code: [Select]
grep -ir skype ~/.config/autostart
« Last Edit: March 30, 2014, 08:06:49 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Problems getting Skype to autostart.
« Reply #11 on: March 31, 2014, 02:59:07 am »
Sorry Mark.  Yes that is a definite typo.  The path should read:
Code: [Select]
/home/andy/.config/autostart/SkypeAutostart
The SkypeAutostart being the file name.  The only two files I have created are the little sleep script that works when tested and the SkypeAutostart one. Here is the output that you have requested. 
Spoiler (click here to view / hide)
andy@andy-AMILO-Li3710 ~ $ grep -ir skype ~/.config/autostart
/home/andy/.config/autostart/skype-15sec-delay.sh:display=:0.0 skype -c /usr/share/applications/Skype
/home/andy/.config/autostart/SkypeAutostart:Name=SkypeAutostart
/home/andy/.config/autostart/SkypeAutostart:Comment=Run Skype delay script
/home/andy/.config/autostart/SkypeAutostart:Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
andy@andy-AMILO-Li3710 ~ $
[close]
I am sorry, it was the .desktop file that threw me for a loop.   That and old wonky eyes. As I said in a previous quote. I added the line:
Code: [Select]
xset s 00
to the top of the file:
Code: [Select]
~/.profile
to resolve a screen blanking issue.  That is the last edit I did before the autostart issue showed itself.

All of the autostart items I have previously made, Conky and Terminator continue to function normally and as expected.
« Last Edit: March 31, 2014, 03:14:15 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems getting Skype to autostart.
« Reply #12 on: March 31, 2014, 08:06:25 am »
OK, run:
Code: [Select]
cd ~/.config/autostart
then
Code: [Select]
rm -v SkypeAutostart
then
Code: [Select]
gedit /home/andy/.config/autostart/skype_autostart.desktop
and make it read:

Code: [Select]
[Desktop Entry]
Type=Application
Name=SkypeAutostart
Comment=Run Skype delay script
Exec=/home/andy/.config/autostart/skype-15sec-delay.sh
Terminal=false
SAVE the file.

Log off/on to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Problems getting Skype to autostart.
« Reply #13 on: March 31, 2014, 08:49:57 am »
That did the trick.  I now have to go and read some more to find out what I was doing wrong  :(.  Many thanks  :).
« Last Edit: March 31, 2014, 09:33:14 am by PCNetSpec »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems getting Skype to autostart.
« Reply #14 on: March 31, 2014, 09:24:35 am »
Please remember to mark the FIRST posting in the topic (SOLVED), not the last one ;)

I've done this one for you.



You'd named the file "SkypeAutostart", insted of say "SkypeAutostart.desktop"

The file needs to be called

some_name_or_other.desktop

Though once you populate it correctly it will display in pcmanfm by the name in the
Name=
line.

.desktop files are odd in this respect, their ACTUAL name needs to end with .desktop .. but when you add a "Name=" line to them their name will APPEAR to change in the GUI file manager .. but not in the command line.
« Last Edit: March 31, 2014, 09:34:54 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec