Choose style:

Author Topic: After installing, the GRUB screen shows up  (Read 11961 times)

0 Members and 1 Guest are viewing this topic.

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #60 on: January 21, 2015, 05:18:29 pm »
I left the original one alone for your question about the 2 Linux partitions, and no unless switch the boot order, or boot from BIOS

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: After installing, the GRUB screen shows up
« Reply #61 on: January 21, 2015, 05:40:06 pm »
Try this....

Open a terminal and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdd5 /mnt
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install --recheck /dev/sdd
then
Code: [Select]
update-grub
now close the terminal and shut down the PC

Now try booting to the external hard drive by selecting it as the first boot device
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #62 on: January 21, 2015, 11:10:30 pm »
I had to shutdown my laptop earlier but when I ran
Code: [Select]
sudo fdisk -l
just to check if anything changed, i noticed sdd changed to sdc so what do I do now?

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
256 heads, 63 sectors/track, 121126 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xd9d7d1a1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  4294967295  2147483647+  ee  GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 15.5 GB, 15512174592 bytes
32 heads, 63 sectors/track, 15028 cylinders, total 30297216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7bae5e37

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63    30296447    15148192+   c  W95 FAT32 (LBA)

Disk /dev/sdc: 1000.2 GB, 1000170586112 bytes
255 heads, 63 sectors/track, 121597 cylinders, total 1953458176 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x50c5766c

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1      1733928958  1953456127   109763585    5  Extended
/dev/sdc2   *        2048    39063551    19530752   83  Linux
/dev/sdc3        39063552  1733926911   847431680   83  Linux
/dev/sdc5      1753458688  1953456127    99998720   82  Linux swap / Solaris
/dev/sdc6      1733928960  1753458687     9764864   82  Linux swap / Solaris

Partition table entries are not in disk order
« Last Edit: January 22, 2015, 03:49:06 am by silver2049 »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: After installing, the GRUB screen shows up
« Reply #63 on: January 22, 2015, 05:05:17 am »
Open a terminal and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdc5 /mnt
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install --recheck /dev/sdc
then
Code: [Select]
update-grub
now close the terminal and shut down the PC

Now try booting to the external hard drive by selecting it as the first boot device
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #64 on: January 22, 2015, 08:11:26 am »
Code: [Select]
sudo mount /dev/sdc5 /mnt
/dev/sdc5 looks like swapspace - not mounted
mount: you must specify the filesystem type
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
mount: mount point /mnt/dev does not exist
mount: mount point /mnt/dev/pts does not exist
mount: mount point /mnt/proc does not exist
mount: mount point /mnt/sys does not exist
mount: mount point /mnt/run does not exist
peppermint@peppermint ~ $ sudo chroot /mnt
chroot: failed to run command ‘/bin/bash’: No such file or directory
peppermint@peppermint ~ $ grub-install --recheck /dev/sdc
Installing for i386-pc platform.
grub-install: error: cannot open directory `/boot/grub/i386-pc': No such file or directory.
peppermint@peppermint ~ $ update-grub
grub-mkconfig: You must run this as root
peppermint@peppermint ~ $ sudo update-grub
/usr/sbin/grub-probe: error: failed to get canonical path of `/cow'.

Is it supposed to give these outputs?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: After installing, the GRUB screen shows up
« Reply #65 on: January 22, 2015, 08:28:41 am »
My apologies, I made a mistake

Open a terminal and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdc3 /mnt
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install --recheck /dev/sdc
then
Code: [Select]
update-grub
now close the terminal and shut down the PC

Now try booting to the external hard drive by selecting it as the first boot device
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #66 on: January 22, 2015, 08:54:27 am »
Code: [Select]
peppermint / # grub-install --recheck /dev/sdc
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

Is this supposed to happen?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: After installing, the GRUB screen shows up
« Reply #67 on: January 22, 2015, 09:54:42 am »
Have you enabled CSM in the BIOS ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #68 on: January 22, 2015, 01:09:03 pm »
When I posted it, no. So I enabled it and it still showed the same error message.

Code: [Select]
peppermint / # grub-install --recheck /dev/sdc
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: After installing, the GRUB screen shows up
« Reply #69 on: January 22, 2015, 01:53:49 pm »
Now that the NTFS partition is missing on that external drive, so you've lost anything from indows that was stored on it .. what I'd do if I were you would be

a) delete ALL partitions on the drive

b) install Peppermint again, creating the 2 partitions as before .. and making SURE to install the bootloader to the root of the external HDD (NOT the internal HDD)

but do ALL this with CSM enabled.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #70 on: January 22, 2015, 10:22:49 pm »
I did it with CSM enabled, I'm still getting all the errors

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: After installing, the GRUB screen shows up
« Reply #71 on: January 23, 2015, 07:52:25 am »
Quote
I'm still getting all the errors

Can you try to  be more descriptive in your responses .. please remember we can't know what you've just done or what the errors are unless you tell us.

What errors ?
and what are you doing when you get the errors ?

The more info you give the better.

What's the make/model of this laptop ?



[EDIT]

OK, I think what's happening here is that Peppermint/GRUB is being installed in EFI mode, but for some reason the EFI partition is being formatted as something other than VFAT (FAT32) .. this explains the 2 "linux" partitions, when you only created one.

So...

We need to create an EFI boot partition before the installation.

First set CSM back to disabled (as that will stop Windows from booting).

Now boot to the LiveCD/LiveUSB .. fire up gparted, and delete ALL partitions on the external HDD .. then as described here:
https://help.ubuntu.com/community/UEFI#Creating_an_EFI_partition
in Gparted create a single partition with these attributes

New size = 200MB
Created as = Primary Partition
File system = FAT32
Label = EFI

Apply that, then once the partition is created, right click on it and select "Manage Flags" and put a tick in the "boot" box.

Close Gparted and fire the installer by clicking on the "Install Peppermint" desktop icon.

As before when you get to the "where to put Peppermint" section choose "Something else" and create 2 partitions in the unparttioned space.
(from here I'm assuming the external HDD is /dev/sdc)

first partition:-

Size = all of the free space except gor 10GB
Type = Primary
Filesystem = EXT4
Mountpoint = /

Second partition

Size = the rest of the free space (approx 10GB)
Type= Logical
Filesystem = Swap

Now at the bottom of the screen make sure the bootloader is placed on
/dev/sdc


« Last Edit: January 23, 2015, 09:18:58 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #72 on: January 23, 2015, 08:22:00 am »
First of all, I repartitioned my external HDD with CSM enabled just as you asked, then reinstalled Peppermint the way you wanted me to. Then when I restart the computer the GRUB screen shows up again. So I open a live session and do the commands like you told me:

Quote
sudo mount /dev/sdc3 /mnt
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install --recheck /dev/sdc
then
Code: [Select]
update-grub

but then i still get the same error from last time where it says:

Quote
Code: [Select]
peppermint / # grub-install --recheck /dev/sdc
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

My laptop model is the ASUS X750JA.
http://www.asus.com/Notebooks_Ultrabooks/X750JA/specifications/
Is the 1 TB HDD, Super-Multi DVD, no Bluetooth version

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25456
  • Karma: 2799
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: After installing, the GRUB screen shows up
« Reply #73 on: January 23, 2015, 09:15:32 am »
Can you see the edit to my last posting :)

Be SURE to change CSM back to disable BEFORE installation ;)

Might also be a good idea to have pre-created a "Boot Repair" LiveUSB just in case:
http://sourceforge.net/p/boot-repair-cd/home/Home/

[EDIT]

The only other thing I can think of if that doesn't work is to change the partition table to GPT before doing what's in the edit to my last posting.

I haven't really had that much experience with UEFI and dual boot .. particularly on an external HDD, and not wanting to risk the Windows installation.
« Last Edit: January 23, 2015, 09:40:12 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline silver2049

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Hopefully 5 by end of month
Re: After installing, the GRUB screen shows up
« Reply #74 on: January 23, 2015, 12:38:18 pm »
I give up, it still doesn't work, I'm just gonna download another distro