Choose style:

Author Topic: screensavers SOLVED  (Read 4306 times)

0 Members and 1 Guest are viewing this topic.

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
screensavers SOLVED
« on: September 16, 2014, 03:42:03 pm »
Can you help configure screensavers to auto run on 5,    message is xscreensaver daemon doesn't seem to running on display  "o"

Regards
Rivers
« Last Edit: September 20, 2014, 07:36:56 am by Rivers »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: screensavers
« Reply #1 on: September 16, 2014, 04:51:37 pm »
Hi Rivers, how's it going?  Navigate to to menu>Preferences>Default applications for LXSession.  In the left hand panel of the new window, click Autostart. In the Known Applications panel, select Screensaver.  Close the window.  That's it.  I hope this helps  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
Re: screensavers
« Reply #2 on: September 17, 2014, 04:18:40 pm »
Hi Rivers, how's it going?  Navigate to to menu>Preferences>Default applications for LXSession.  In the left hand panel of the new window, click Autostart. In the Known Applications panel, select Screensaver.  Close the window.  That's it.  I hope this helps  ;).
Hi, Thanks for the above, have found it and tried the autostart under known apps, it's not working, the box un-ticks after closing.

Rivers

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: screensavers
« Reply #3 on: September 17, 2014, 04:38:43 pm »
Try this .. run:
Code: [Select]
gedit ~/.config/autostart/xscreensaver-autostart.desktop
when a BLANK file opens, make it read:-
Code: [Select]
[Desktop Entry]
Type=Application
Name=xcreensaver autortart
Comment=Change screensaver properties
Exec=xscreensaver -nosplash
Icon=xscreensaver
Terminal=false
Categories=Settings;DesktopSettings;Security;X-XFCE;
SAVE the file and exit gedit.

Log off/on

See if
menu > Preferences > Screensaver
stll gives that error
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
Re: screensavers
« Reply #4 on: September 18, 2014, 08:57:06 am »
Hi Thanks for this,  the code has not worked the screensaver box remains unticked after close.

Rivers

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: screensavers
« Reply #5 on: September 18, 2014, 12:33:32 pm »
Which screensaver box .. I didn't expect any box to stay ticked.  :-\

I just wanted to know if when you run

menu > Preferences > Screensaver

You still get the error xscreensaver daemon doesn't seem to running on display  "o" or not ?

If you don't .. xscreensavers is autostarting correctly .. so try setting a screensaver.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
Re: screensavers
« Reply #6 on: September 18, 2014, 03:25:54 pm »
I was referring to the enabled application box.? now having reinstalled from the disc screensavers no longer appears preferences.

This problem I have is non essential, just would like to work as I have on P3

Regards Rivers

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: screensavers
« Reply #7 on: September 18, 2014, 04:25:44 pm »
Run:
Code: [Select]
sudo apt purge light-locker light-locker-settings
then
Code: [Select]
sudo apt install xscreensaver xscreensaver-gl
then
Code: [Select]
gedit ~/.config/autostart/xscreensaver-autostart.desktop
and make it read:-
Code: [Select]
[Desktop Entry]
Type=Application
Name=xcreensaver autortart
Comment=Change screensaver properties
Exec=xscreensaver -nosplash
Icon=xscreensaver
Terminal=false
Categories=Settings;DesktopSettings;Security;X-XFCE;
SAVE the file.

Log off/on (or reboot)

test
menu > Preferences > Screensaver
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
Re: screensavers SOLVED
« Reply #8 on: September 19, 2014, 06:34:42 am »
Many thanks now restored.
Regards
Rivers

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: screensavers
« Reply #9 on: September 19, 2014, 06:39:52 am »
You're most welcome :)

Can you please remember to mark the FIRST posting in the topic as (SOLVED), not the last posting .. otherwise it doesn't get updated in all the forum menus .. TIA :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
Re: screensavers
« Reply #10 on: September 25, 2014, 12:10:57 pm »
Hi, Sorry to say I have just returned to the screensaver issue but over looked the auto run part,otherwise it runs fine



xscreensaver daemon does not seem to be running on display '0'

regards Rivers
« Last Edit: September 27, 2014, 06:10:06 am by Rivers »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: screensavers SOLVED
« Reply #11 on: September 25, 2014, 12:47:12 pm »
So is it autostarting now or not ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
Re: screensavers SOLVED
« Reply #12 on: September 25, 2014, 03:01:58 pm »
No it will not run without a manual start.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: screensavers SOLVED
« Reply #13 on: September 25, 2014, 04:11:39 pm »
run:
Code: [Select]
gedit ~/.config/autostart/xscreensaver-autostart.desktop
and post the contents

Also post the output from:
Code: [Select]
ls -a ~/.config/autostart
« Last Edit: September 25, 2014, 04:13:18 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Rivers

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 0
  • New Forum User
    • View Profile
Re: screensavers SOLVED
« Reply #14 on: September 26, 2014, 04:52:09 am »
Type=Application
Name=xcreensaver autortart
Comment=Change screensaver properties
Exec=xscreensaver -nosplash
Icon=xscreensaver
Terminal=false
Categories=Settings;DesktopSettings;Security;X-XFCE;

.                     peppermint-control-center.desktop
..                    xbindkeys.desktop
light-locker.desktop  xscreensaver-autostart.desktop
nm-applet.desktop     xscreensaver-autostart.desktop

Posted returns