Author Topic: CPU fan does not work with Peppermint OS  (Read 164 times)

Offline 13islander

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 1
  • New To PeppermintOS/Linux
    • View Profile
  • Peppermint version(s): 10
CPU fan does not work with Peppermint OS
« on: November 09, 2020, 05:18:42 am »
Hi,

I'm trying to find a solution to overheating (and switch off) due to CPU fan not working when Peppermint is running. (I've just installed Peppermint as my OS in place of Vista.)

In researching online I think I've narrowed it down to a solution of either BIOS update or Kernel change.

Does anybody have any insight into why CPU fan does not cut-in to protect against overheat and solution advice?

Hardware:
System:    Host: maureen-Aspire-5315 Kernel: 5.4.0-52-generic i686
           bits: 32 gcc: 7.5.0
           Desktop: N/A Distro: Peppermint Ten
Machine:   Device: other-vm? System: Acer product: Aspire 5315 v: V1.18 serial: N/A
           Mobo: Acer model: Acadia v: V1.18 serial: N/A
           BIOS: Acer v: V1.18 date: 09/27/2007
Battery    BAT0: charge: 7.5 Wh 25.0% condition: 30.1/44.4 Wh (68%)
           model: SANYO GC86508SAT0 status: Discharging
CPU:       Single core Intel Celeron 530 (-UP-) arch: Conroe rev.1 cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 3458 speed: 1729 MHz (max)
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.20.8 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.00hz
           OpenGL: renderer: Mesa DRI Intel 965GM (CL)
           version: 2.1 Mesa 20.0.8 Direct Render: Yes
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k5.4.0-52-generic
Network:   Card-1: Broadcom and subsidiaries NetLink BCM5906M Fast Ethernet PCIE
           driver: tg3 v: 3.137 bus-ID: 05:00.0
           IF: enp5s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express)
           driver: ath5k bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>
Drives:    HDD Total Size: 80.0GB (29.7% used)
           ID-1: /dev/sda model: Hitachi_HTS54258 size: 80.0GB temp: 36C
Partition: ID-1: / size: 73G used: 23G (33%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 83.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 152 Uptime: 40 min Memory: 442.4/2001.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.5.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56


Temp Sensor:
coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +83.0°C  (high = +100.0°C, crit = +100.0°C)

Thanks,

« Last Edit: November 09, 2020, 05:32:05 am by 13islander »
Cheers, 13islander

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1291
  • Karma: 151
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: CPU fan does not work with Peppermint OS
« Reply #1 on: November 20, 2020, 12:52:44 pm »
Hi 13islander, check out this site, may be what you need.
https://askubuntu.com/questions/1166768/gui-to-control-fanspeed-in-ubuntu
I found this by doing an internet search for "fan controls in ubuntu"
What was I thinking?

Offline 13islander

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 1
  • New To PeppermintOS/Linux
    • View Profile
  • Peppermint version(s): 10
Re: CPU fan does not work with Peppermint OS
« Reply #2 on: November 24, 2020, 04:54:47 am »
Hi 13islander, check out this site, may be what you need.
https://askubuntu.com/questions/1166768/gui-to-control-fanspeed-in-ubuntu
I found this by doing an internet search for "fan controls in ubuntu"

Sorry alynur I missed your reply to my question. (A combination of unfamiliarity with forum mechanics, no email notification service request by me, and time limitations due to overheating problem.......I’m now viewing the forum on my iPad so no more excuses till next time!)

As to your suggestion I believe it won’t work with my device which doesn’t have fan variable speed control (it seems it has a binary switching function on or off depending on temp sensor thresholds).  I tried your suggestion anyway but it came back with “Unable to locate package lib”.

Having done my own further research in the meantime I’m getting closer to understanding and solving the problem. (see an update I will post next)

Thanks I appreciate your efforts.
« Last Edit: November 24, 2020, 05:05:09 am by 13islander »
Cheers, 13islander

Offline 13islander

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 1
  • New To PeppermintOS/Linux
    • View Profile
  • Peppermint version(s): 10
Re: Acer 5315 CPU fan does not work with Peppermint OS (SOLVED)
« Reply #3 on: November 24, 2020, 12:36:32 pm »
I found the reason and solution to my problem on the Linux Mint forum:-

REASON: “Apparently, these laptops came with a special version of WinVista that handled the fan, so there's no fan handling routines in the original BIOS.” This may not be quite correct (as the fan also works while the BIOS editor is in held on screen) but in essence it is the case. So when I replaced Vista with Peppermint the fan stopped working.

SOLUTION: All you have to do is update the BIOS (ver 1.45, which handles the fan differently)........ahh but it’s not so easy! To update the BIOS you must use an executable file which only works under Windows. So after much fiddling I got an older version of Hirens (15.2) onto USB which allowed Mini XP to be run on the Laptop. On a Win netbook I have I downloaded a copy of the updated BIOS exe onto another USB and then plugged this into a secondary port on the problem laptop. I then fired up the new BIOS and bingo job done!

For info, in frustration, I was very close to an alternative solution.....that of switching the wiring on the fan to the full voltage supply so it would be running full time (it’s a really quiet fan).

Got there in the end!
Cheers, 13islander

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2202
  • Karma: 459
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: CPU fan does not work with Peppermint OS
« Reply #4 on: November 24, 2020, 12:37:39 pm »
Great work there  ;)

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5902
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: CPU fan does not work with Peppermint OS
« Reply #5 on: November 24, 2020, 12:50:14 pm »
Good job, Detective 13islander!   :)







Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1291
  • Karma: 151
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: CPU fan does not work with Peppermint OS
« Reply #6 on: November 25, 2020, 09:49:13 am »
Glad you fixed your problem, now if you could add solved to your subject, others can benefit from your discoveries. That's pretty much how we all help each other here.
What was I thinking?

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 3031
  • Karma: 345
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): Peppermint 10 Respin
Re: CPU fan does not work with Peppermint OS
« Reply #7 on: November 25, 2020, 02:19:21 pm »
Glad you fixed your problem, now if you could add solved to your subject, others can benefit from your discoveries. That's pretty much how we all help each other here.

 8)

Here's a Tutorial on how to mark your topic (SOLVED)  https://forum.peppermintos.com/index.php/topic,24.0.html

 ;)
spence
PeppermintOS 10 Respin currently installed  on:
'16 Antec Aria rebuild
& '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.