Author Topic: [Solved]Opening Devices as root  (Read 196 times)

Offline newb85

  • Jr. Member
  • **
  • Posts: 26
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
[Solved]Opening Devices as root
« on: October 07, 2020, 08:37:23 pm »
So, when I hook up my Android phone through USB, it's like I don't have any permissions for the device.  I can click on it under "Devices" in the Places side panel of Nemo, but nothing shows up.  If I right-click the empty space and "Open as Root", I just get an error message that it could not display because the location is not a folder.  Right-clicking it under devices doesn't give the "Open as Root" option.  Is there a good way to do this?
« Last Edit: October 10, 2020, 04:38:14 am by newb85 »

Offline invisible

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 9
  • Peppermint & Ubuntu
    • View Profile
  • Peppermint version(s): 10
Re: Opening Devices as root
« Reply #1 on: October 08, 2020, 03:33:26 am »
I assume that this is about file transfer rather than rooting the OS on your phone.
To transfer files to/from an Android phone to your Peppermint PC, you do not need root permissions.

However, you have to enable the visibility of your phone via Android. The following is for Android version 10.

Hook up the phone via usb cable.
Android settings > Connected devices > USB > USB Controlled by This Device (selected) > File Transfer (selected)

Hopefully, your phone storage will now appear in Nemo (Peppermint File Manager)

Offline newb85

  • Jr. Member
  • **
  • Posts: 26
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Opening Devices as root
« Reply #2 on: October 09, 2020, 08:50:15 am »
You're correct. Yes, that used to work.  But my phone is on android 11, now, and none of the file system of the phone is showing up in nemo, anymore. And I did make sure to set the phone to file transfer mode.  When I right click the phone on the desktop and select properties, it tells me the file permissions can't be determined.  It seems like when they updated the android OS, they changed how the fs and permissions work.

Offline invisible

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 9
  • Peppermint & Ubuntu
    • View Profile
  • Peppermint version(s): 10
Re: Opening Devices as root
« Reply #3 on: October 09, 2020, 10:38:21 am »
That sounds like a regression in Android 11 rather than a Peppermint OS problem.

Nevertheless, it's certainly frustrating. Are you a member of any Android user forums - perhaps there may be others using Android 11 with the same dilemma?

Double check that you have ticked USB Controlled by This Device on your phone.
Alternatively, does your phone have a removable micro SD card?
Possibly, consider file transfer via one of the cloudy cloud services?


Offline rayzer

  • Trusted User
  • Member
  • *****
  • Posts: 426
  • Karma: 161
  • Graphics n Stuff
    • View Profile
  • Peppermint version(s): 10 Respin
Re: Opening Devices as root
« Reply #4 on: October 09, 2020, 02:31:15 pm »
something to try, been a while since i had to do it myself..

on android, go into your about android settings and click on build number a few times until it says your now a developer then in developer options enable usb debugging

on peppermint, try installing usbmuxd mtp-tools pmount usbmount

once its all done try reconnecting the phone and see if it shows up. if so then open nemo as root using sudo nemo
For wallpapers ive made you can download them here

Offline newb85

  • Jr. Member
  • **
  • Posts: 26
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Opening Devices as root
« Reply #5 on: October 10, 2020, 04:36:48 am »
@invisible,

I agree that it seems like an android regression.  But it does startle me that things still work normally from Windows.

@rayzeer,
Thanks! the USB Debugging did the trick.