Author Topic: RX 570 Black Screen with 5 series & late 4 series kernels  (Read 768 times)

Offline Linux Lover

  • Newly Subscribed
  • *
  • Posts: 19
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 (x64)
RX 570 Black Screen with 5 series & late 4 series kernels
« on: September 28, 2020, 02:36:20 pm »
I recently bought an RX 570 8GB from XFX that gives a black screen upon booting into kernel 5.7.1.  After quite a bit of testing (tested with a different distro--Ubuntu 20.04 & tried different kernels) and reading online, this has occured for other RX 570 & 580 users online under different parameters in Linux & sometimes in Windows.  In my case, I saw that other Linux users encountered the same problem of a black screen at boot into their distro(s).  They recommended going into grub & changing some wording around in order to achieve some type of flag to get it to boot.  The problem in my case, seems to be exclusive to Peppermint 10 w/newer kernels (those beyond 4.18 iirc).  I can still use PM 10 w/this new gpu as long as I run kernel 4.18.18.  Upon testing with Ubuntu 20.04, I discovered that the problem does not exist there.  Is it possible for the Peppermint team to put the flag that allows this gpu series (RX 570/580) to be properly used since whatever it is, must already be included in Ubuntu 20.04?   I have saved some links discussing the issue, but will not make this any longer than it needs to be and if anyone wanting to help needs these links for reference I will post as a response later.  Thank you for any assistance.  My HW specs are listed below for help.

AMD FX-6300 @ Stock 3.5GHz
990FXA-UD3 GIGABYTE MOTHERBOARD
32GB DDR3-1866 (CPU/MOBO LIMITED TO 1600 SPEED PER AMD LOCK)
AX-760W CORSAIR PLATINUM PSU
XFX AMD RX 570 8GB
PM 10 x64 (with oibaf ppa; vulkan)

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1275
  • Karma: 137
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: RX 570 Black Screen with 5 series & late 4 series kernels
« Reply #1 on: September 29, 2020, 04:18:09 pm »
While you are in Ubuntu, could you install inxi and then run

Code: [Select]
inxi -Fz
and paste the results back here?
What was I thinking?

Offline Linux Lover

  • Newly Subscribed
  • *
  • Posts: 19
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10 (x64)
Re: RX 570 Black Screen with 5 series & late 4 series kernels
« Reply #2 on: September 29, 2020, 04:54:39 pm »
Thank you for your response.  Here it is:


ubuntu@Challenger:~$ inxi -Fz
System:
  Kernel: 5.8.11-050811-generic x86_64 bits: 64 Desktop: Gnome 3.36.4
  Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter>
  Mobo: Gigabyte model: 990FXA-UD3 v: x.x serial: <filter>
  BIOS: American Megatrends v: F3 date: 05/28/2015
CPU:
  Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP L2 cache: 2048 KiB
  Speed: 1764 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1403 2: 1404
  3: 1416 4: 1439 5: 1444 6: 1484
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
  driver: amdgpu v: kernel
  Display: x11 server: X.Org 1.20.8 driver: amdgpu
  resolution: 1680x1050~60Hz
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.38.0
  5.8.11-050811-generic LLVM 10.0.1)
  v: 4.6 Mesa 20.3.0-devel (git-f590148 2020-09-29 focal-oibaf-ppa)
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.8.11-050811-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k
  IF: wlp8s0 state: down mac: <filter>
Drives:
  Local Storage: total: 3.07 TiB used: 414.11 GiB (13.2%)
  ID-1: /dev/sda vendor: Crucial model: M4-CT128M4SSD2 size: 119.24 GiB
  ID-2: /dev/sdb vendor: Western Digital model: WDBNCE0010PNC
  size: 931.51 GiB
  ID-3: /dev/sdc vendor: Western Digital model: WD5000LPVT-24G33T1
  size: 465.76 GiB
  ID-4: /dev/sdd vendor: Hitachi model: HTS545025B9A300 size: 232.89 GiB
  ID-5: /dev/sde vendor: Samsung model: HD103UJ size: 931.51 GiB
  ID-6: /dev/sdf vendor: Hitachi model: HDT721050SLA360 size: 465.76 GiB
Partition:
  ID-1: / size: 19.56 GiB used: 11.13 GiB (56.9%) fs: ext4 dev: /dev/sde5
  ID-2: /home size: 19.56 GiB used: 10.05 GiB (51.4%) fs: ext4
  dev: /dev/sde6
Sensors:
  System Temperatures: cpu: 34.6 C mobo: N/A gpu: amdgpu temp: 38 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1067
Info:
  Processes: 290 Uptime: 18m Memory: 31.38 GiB used: 1.93 GiB (6.2%)
  Shell: bash inxi: 3.0.38

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1275
  • Karma: 137
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: RX 570 Black Screen with 5 series & late 4 series kernels
« Reply #3 on: September 29, 2020, 09:27:10 pm »
check if this discussion helps you. https://forums.linuxmint.com/viewtopic.php?t=310609

What was I thinking?