Author Topic: Permission denied(SOLVED)  (Read 396 times)

Offline straybit

  • Member
  • ***
  • Posts: 52
  • Karma: 9
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Permission denied(SOLVED)
« on: September 25, 2020, 10:08:29 am »
This is the second program that I've compiled and get this error
Code: [Select]
bruce@Compaq ~/Data/bin/lib $ gcc -Wall -L. -oLibTest LibTest.c -lbrlib
bruce@Compaq ~/Data/bin/lib $ ./LibTest
bash: ./LibTest: Permission denied
bruce@Compaq ~/Data/bin/lib $ ls -l
total 40
-rw-rw-r-- 1 bruce bruce 15864 Sep 24 15:05 libbrlib.a
-rwxrwxr-x 1 bruce bruce 13224 Sep 25 10:41 LibTest
-rw-rw-r-- 1 bruce bruce   801 Sep 25 10:36 LibTest.c
drwxr-xr-x 2 bruce bruce  4096 Sep 25 10:09 src
Here is inxi
Spoiler (click here to view / hide)
[close]
just read another message.  I don't know if this is wanted but
Code: [Select]
bruce@Compaq ~/Data $ uname -a
Linux Compaq 5.0.0-37-generic #40~18.04.1-Ubuntu SMP Thu Nov 14 12:06:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Any suggestion?
Bruce
« Last Edit: October 01, 2020, 12:19:03 pm by straybit »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2180
  • Karma: 457
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Permission denied
« Reply #1 on: September 25, 2020, 02:32:36 pm »
Make sure Data isn't mounted with noexec parameter and that the whole path (every folder) of ?/Data/bin/lib is marked as executable.

Offline straybit

  • Member
  • ***
  • Posts: 52
  • Karma: 9
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Re: Permission denied
« Reply #2 on: September 26, 2020, 01:54:37 pm »
Thanks Murraymint.
Here is the fstab entry
Spoiler (click here to view / hide)
[close]
All folders are
Code: [Select]
drwxr-xr-x

Offline straybit

  • Member
  • ***
  • Posts: 52
  • Karma: 9
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Re: Permission denied(SOLVED)
« Reply #3 on: October 01, 2020, 12:24:25 pm »
My Data directory is on a different partition.  In fstab, one of the options is 'users' which implies 'noexec' and others.
My solution was to add 'exec,' after 'users'.
Bruce